Canadian Airgun Forum

The #1 Community for Airguns in Canada!
It is currently Mon Dec 09, 2019 3:23 pm

All times are UTC - 5 hours


The Canadian Airgun Forums are a place for people to discuss and learn about airguns and the airgunning sport in Canada. There are lots of discussions about airguns, airgun accessories, reviews, modification and repair information, airgun events, field target and free classifieds!

 

You need to register before you can post: click the register link to proceed. Before you register, please read the forum rules. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload your own pictures, and access many other special features. Registration is fast, simple, and absolutely free! To start viewing messages, select the forum that you want to visit from the selection below.








Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Fri Jul 04, 2014 2:37 pm 
Offline
User avatar

Joined: Fri Nov 02, 2012 8:41 pm
Posts: 1253
Location: Brant County
Okay I picked up a medalist from a bud that was shooting weak! i said yeah i can fix that (solved this problem on 4 different guns since february lol) and weak i mean 200fps weak on 10 pumps! ive swapped every single part on this gun and still cant get any power :( it feels like it only takes 1 pump and nothing else, ive swapped main tubes, seals, valvestems, check valves... and still same results! what the heck am i doing wrong? i think i have the right size seals but cant see this problem being from anything else! im very frustrated and seems this gun is fubar'ed yet im determined to solve this problem! i have limited o-ring sources around here so im hoping im just doing something wrong lol

Thanks yall your input is much appreciated!

_________________
It's better to die quick fighting on your feet, then to live forever begging on your knees - Lamb Of God


Top
 Profile  
 
PostPosted: Fri Jul 04, 2014 4:14 pm 
Offline
User avatar

Joined: Mon Feb 11, 2013 12:46 am
Posts: 4174
Hard to tell what could be wrong with it if your saying you've changed most of the stuff out and its still shooting low fps . :?
Check your pm :wink:

_________________
"A candle loses nothing by lighting another candle"

Image


Top
 Profile  
 
PostPosted: Fri Jul 04, 2014 5:49 pm 
Offline
User avatar

Joined: Fri Nov 02, 2012 8:41 pm
Posts: 1253
Location: Brant County
i think i may have used all my 13xx orings and perhaps a new'er pump cup is in order?! i just dont know ive literally tried EVERYTHING including tubes (1322 to a 2289 tube) and nothing seems to work! :evil:

_________________
It's better to die quick fighting on your feet, then to live forever begging on your knees - Lamb Of God


Top
 Profile  
 
PostPosted: Fri Jul 04, 2014 5:58 pm 
Offline
Supporting Member 2009
User avatar

Joined: Sun Dec 24, 2006 12:37 am
Posts: 3468
Location: Out There
Swap the entire valve and put on a new pump cup- complete valve is $12.00, pump cup seal is $2.00- likely not a 'bank breaker'.

The idea of spending hours and hours to save $15.00 in parts may not be terribly worthwhile unless someone has alot of free time.

_________________
www.scopesandammo.com/storefront



Please note: I do not conduct business through Private Messages (PM's) in online forums. Please do not send a 'PM" with a business-related question.


Top
 Profile  
 
PostPosted: Sun Jul 06, 2014 12:22 pm 
Offline

Joined: Mon Mar 09, 2009 6:46 pm
Posts: 1395
Location: r Alberta
Check you have the right springs for the hammer and the valve.


Top
 Profile  
 
PostPosted: Mon Jul 07, 2014 10:53 am 
Offline
User avatar

Joined: Fri Nov 02, 2012 8:41 pm
Posts: 1253
Location: Brant County
i think your right Eric :( i gota pick some parts up off ya anyway lol

_________________
It's better to die quick fighting on your feet, then to live forever begging on your knees - Lamb Of God


Top
 Profile  
 
PostPosted: Mon Jul 07, 2014 12:01 pm 
Offline
User avatar

Joined: Mon Feb 11, 2013 12:46 am
Posts: 4174
I would start with the pump cup they seam to harden up and loose there flexibility to seal against to tube and are the first thing to go on these pumpers. :wink:

_________________
"A candle loses nothing by lighting another candle"

Image


Top
 Profile  
 
PostPosted: Mon Jul 07, 2014 3:28 pm 
Offline

Joined: Wed Mar 27, 2013 9:51 pm
Posts: 89
Location: California USA
Only one pump velocity is caused by the check poppet not sealing. It's a brass valve, so clean the seat area, and clean or replace the poppet. The early poppets used an O-ring for the seal. Replacing the early type with a Teflon later type cures most check problems.


Top
 Profile  
 
PostPosted: Mon Jul 07, 2014 3:51 pm 
Offline
User avatar

Joined: Fri Nov 02, 2012 8:41 pm
Posts: 1253
Location: Brant County
Big Bore Bart wrote:
Only one pump velocity is caused by the check poppet not sealing. It's a brass valve, so clean the seat area, and clean or replace the poppet. The early poppets used an O-ring for the seal. Replacing the early type with a Teflon later type cures most check problems.


ive swapped the brass valve with a aluminum valve to see if it was the valve :( perhaps the pump cup route is the way to go lol i have 3 but im guessing they are all fubar'ed

_________________
It's better to die quick fighting on your feet, then to live forever begging on your knees - Lamb Of God


Top
 Profile  
 
PostPosted: Mon Jul 07, 2014 6:11 pm 
Offline
Supporting Member 2009
User avatar

Joined: Tue Aug 21, 2007 5:25 pm
Posts: 615
Location: Burl, Ont.
Pump it a few times then open the pump lever all the way.
Dry fire it,(unloaded/safe direction}. If it does nothing your check valve is bad/in wrong.


Top
 Profile  
 
PostPosted: Mon Jul 14, 2014 12:19 am 
Offline

Joined: Wed Jun 25, 2014 1:54 pm
Posts: 87
Location: Edmonton, AB
Transfer port in the right way??


Top
 Profile  
 
PostPosted: Wed Jul 30, 2014 9:26 pm 
Offline
User avatar

Joined: Fri Nov 02, 2012 8:41 pm
Posts: 1253
Location: Brant County
Sorry to leave yall hanging but i did manage to get her firing ;) took every rough edge in the maintube off and bought a boatload of the CORRECT size o-rings and now all is well :) think i may have mixed up a few sizes in my box and "assumed" they were still all correct :( complete DUH moment at its finest but thank yall very very much for the input!!! ;)

_________________
It's better to die quick fighting on your feet, then to live forever begging on your knees - Lamb Of God


Top
 Profile  
 
PostPosted: Wed Jul 30, 2014 9:33 pm 
Offline
User avatar

Joined: Thu Feb 02, 2006 11:35 pm
Posts: 3099
Location: Alberta Canada
My question to this thread is, If your going to rebuild an airgun. Why would you not replace all the components that wear, ie orings, pump cups and such to begin with?

_________________
May the cry of the pack be with you upon your hunt

Whitewolf


Top
 Profile  
 
PostPosted: Wed Jul 30, 2014 9:39 pm 
Offline
User avatar

Joined: Mon Feb 11, 2013 12:46 am
Posts: 4174
He did Kim, he just admitted he mixed up the o-ring for the correct size thus the reason it didn't hold pressure :lol: :wink:

_________________
"A candle loses nothing by lighting another candle"

Image


Top
 Profile  
 
PostPosted: Wed Jul 30, 2014 10:19 pm 
Offline
User avatar

Joined: Thu Feb 02, 2006 11:35 pm
Posts: 3099
Location: Alberta Canada
Ace wrote:
He did Kim, he just admitted he mixed up the o-ring for the correct size thus the reason it didn't hold pressure :lol: :wink:

Yes read that. Was just caught reading the time lines. 3 days to deduce pump cup, and reported 26 days later of an oring. Just throwing it out there, would not a set of calipers and doing a few minutes of measuring have saved a world of time.. :wink: :wink: Just wondering.

_________________
May the cry of the pack be with you upon your hunt

Whitewolf


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
News News Site map Site map SitemapIndex SitemapIndex RSS Feed RSS Feed Channel list Channel list

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

phpBB SEO