Canadian Airgun Forum
https://www.airgunforum.ca/forums/

Umarex Steel Force Not Firing
https://www.airgunforum.ca/forums/topic59963.html
Page 1 of 2

Author:  Jared [ Sun Jan 19, 2014 2:44 pm ]
Post subject:  Umarex Steel Force Not Firing

Hey folks. So I went out with my friends yesterday to go target shooting. I was excited as I have just put on a bunch of accessories for it which I recently purchased. When I went to fire, it was able to shoot a few BBs out in single fire mode, but after a few shots it just stopped firing altogether.

I can pull the trigger down many, many times and it doesn't fire, not in single or 6 burst mode.

I thought maybe it was the temperature (even though I've been able to shoot in colder temps than yesterday and my friend was able to keep shooting his Steel Storm with no problems) so I waited till I brought it back home and for the guns internals to warm up. I attempted another test fire but still, pulled the trigger and nothing came out.

Has anyone had this problem, and if so, is it an easy fix or will I have to send it back to the company I bought it from (replicaairguns.ca)

All in all, I'm really pissed off about this. I've only fired maybe 6000 BBs through it over the course of 4 outings and now it's broken, even though I treated it very lightly, always making sure it was never dropped or damaged.

Cheers

Author:  paddyfritz [ Sun Jan 19, 2014 6:10 pm ]
Post subject:  Re: Umarex Steel Force Not Firing

The bolt likely needs lube. The trigger may also not be traveling far enough. Try lubing it liberally. You can also place a shim behind the trigger to see if that is the issue.

Author:  Jared [ Mon Jan 20, 2014 3:48 am ]
Post subject:  Re: Umarex Steel Force Not Firing

paddyfritz wrote:
The bolt likely needs lube. The trigger may also not be traveling far enough. Try lubing it liberally. You can also place a shim behind the trigger to see if that is the issue.


I'm not sure where to even begin with where and how to lube it. I'm new to airguns. This is my first airgun.

Would that all require me to open the gun up? I've read several times that opening up the gun is easy but closing it all back up again is a nightmare.

Author:  paddyfritz [ Mon Jan 20, 2014 5:04 am ]
Post subject:  Re: Umarex Steel Force Not Firing

Jared wrote:
paddyfritz wrote:
The bolt likely needs lube. The trigger may also not be traveling far enough. Try lubing it liberally. You can also place a shim behind the trigger to see if that is the issue.


I'm not sure where to even begin with where and how to lube it. I'm new to airguns. This is my first airgun.

Would that all require me to open the gun up? I've read several times that opening up the gun is easy but closing it all back up again is a nightmare.


You would need to take it apart,
After cocking it, pull the trigger and bang on the side. The bolt may slide forward if its sticking. That will not fix it, but it may let you know that is the problem.

If its under warranty, you may want to send it back.

Author:  Jared [ Mon Jan 20, 2014 11:20 am ]
Post subject:  Re: Umarex Steel Force Not Firing

paddyfritz wrote:
Jared wrote:
paddyfritz wrote:
The bolt likely needs lube. The trigger may also not be traveling far enough. Try lubing it liberally. You can also place a shim behind the trigger to see if that is the issue.


I'm not sure where to even begin with where and how to lube it. I'm new to airguns. This is my first airgun.

Would that all require me to open the gun up? I've read several times that opening up the gun is easy but closing it all back up again is a nightmare.


You would need to take it apart,
After cocking it, pull the trigger and bang on the side. The bolt may slide forward if its sticking. That will not fix it, but it may let you know that is the problem.

If its under warranty, you may want to send it back.


Cool, thanks paddy

Author:  Ace [ Mon Jan 20, 2014 11:54 am ]
Post subject:  Re: Umarex Steel Force Not Firing

sounds like something in your trigger mechanism probably not making contact.
this guy had the same problem and sent his back and got a new one, if yours is still under warranty why bother trying to fix it get a new one, you paid for that service. :wink:
http://www.airgunone.com/forums/showthread.php?t=7250

Author:  paddyfritz [ Mon Jan 20, 2014 2:25 pm ]
Post subject:  Re: Umarex Steel Force Not Firing

Ace wrote:
sounds like something in your trigger mechanism probably not making contact.
this guy had the same problem and sent his back and got a new one, if yours is still under warranty why bother trying to fix it get a new one, you paid for that service. :wink:
http://www.airgunone.com/forums/showthread.php?t=7250


I have seen it on a few. Its usually what I said.
If its under warranty send it back. Otherwise, they are not that hard to fix, but they are somewhat "springy" inside.

Author:  Jared [ Tue Jan 21, 2014 6:50 pm ]
Post subject:  Re: Umarex Steel Force Not Firing

Ace wrote:
sounds like something in your trigger mechanism probably not making contact.
this guy had the same problem and sent his back and got a new one, if yours is still under warranty why bother trying to fix it get a new one, you paid for that service. :wink:
http://www.airgunone.com/forums/showthread.php?t=7250


Yup, you're absolutely right. I've contacted Mike at replicaairguns.ca and am asking for a warranty replacement. We'll see what he says.

Author:  Ace [ Tue Jan 21, 2014 7:01 pm ]
Post subject:  Re: Umarex Steel Force Not Firing

Let us know what happens

Author:  Canadianguy [ Wed Jan 22, 2014 10:59 am ]
Post subject:  Re: Umarex Steel Force Not Firing

Hi....i have 2 of these and one had to be returend to Airgun Source because it did the same problem as yours It sounds.They replaced it the next day no questions.Not sure why it did it..

2 cents

Author:  paddyfritz [ Wed Jan 22, 2014 11:09 am ]
Post subject:  Re: Umarex Steel Force Not Firing

It can also do that if the little coil spring comes off the trigger linkage.

Author:  Jared [ Sat Jan 25, 2014 11:30 pm ]
Post subject:  Re: Umarex Steel Force Not Firing

Ace wrote:
Let us know what happens


Looks like Mike at replicaairguns.ca doesn't want to exvhange it back for one that works. He has a 30 day policy.

paddyfritz wrote:
It can also do that if the little coil spring comes off the trigger linkage.


Since replicaairguns.ca isn't willing to exchange it, I'll have to call Umarex and see if they'll replace it. If all else fails, I have no choice but to open it up myself and attempt to fix it.

Canadianguy wrote:
Hi....i have 2 of these and one had to be returend to Airgun Source because it did the same problem as yours It sounds.They replaced it the next day no questions.Not sure why it did it..

2 cents


Well, if Umarex won't replace it, I hope I can fix it, otherwise I will be ordering from Airgunsource, since they seemed to be willing to do a replacement for you, unlike replicaairguns.ca, whom I probably won't be purchasing from again...

Author:  Jared [ Sun Jan 26, 2014 4:22 pm ]
Post subject:  Re: Umarex Steel Force Not Firing

Well..... Seeing as Umarex won't ship replacements to Canada, I decided to take a stab at repairing it myself, seeing as what do I have to lose...

I opened it up and the thing exploded into 100 or more different bits and springs and tiny little pieces LOL

So I looked the mess that had just been created and said to myself...well, looks like I have a bunch of replacement parts if I ever need any...

Ordering from airgunsource after this post. Hopefully this doesn't happen again!

Author:  Canadianguy [ Sun Jan 26, 2014 4:33 pm ]
Post subject:  Re: Umarex Steel Force Not Firing

There are a lot pics out there of the inside of it! I wish they would stock something like the spring for the bb feed.Did you take the reciever apart?

Author:  paddyfritz [ Sun Jan 26, 2014 4:36 pm ]
Post subject:  Re: Umarex Steel Force Not Firing

Jared wrote:
Well..... Seeing as Umarex won't ship replacements to Canada, I decided to take a stab at repairing it myself, seeing as what do I have to lose...

I opened it up and the thing exploded into 100 or more different bits and springs and tiny little pieces LOL

So I looked the mess that had just been created and said to myself...well, looks like I have a bunch of replacement parts if I ever need any...

Ordering from airgunsource after this post. Hopefully this doesn't happen again!


I have some photos on my photobucket page that may help you if you have the important parts.
Many of the parts on the outside of the zinc receiver are the burst fire parts and you dont need them.
I did warn you it was springy.
Did you separate the two halves of the zinc receiver, and have those parts fly out or did you not get that far ?

Page 1 of 2 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/