Canadian Airgun Forum

The #1 Community for Airguns in Canada!
It is currently Sun Nov 17, 2019 5:25 am

All times are UTC - 5 hours


The Canadian Airgun Forums are a place for people to discuss and learn about airguns and the airgunning sport in Canada. There are lots of discussions about airguns, airgun accessories, reviews, modification and repair information, airgun events, field target and free classifieds!

 

You need to register before you can post: click the register link to proceed. Before you register, please read the forum rules. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload your own pictures, and access many other special features. Registration is fast, simple, and absolutely free! To start viewing messages, select the forum that you want to visit from the selection below.








Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Thu Jun 30, 2016 7:15 pm 
Offline

Joined: Fri Dec 18, 2015 11:31 pm
Posts: 92
I was seeing poor power levels (600fps) in an HW98 that I bought used, so I replaced the spring and piston seal with new OEM parts and added an HDPE sleeve inside the piston.

I'm seeing increased performance, but not quite at the levels I was expecting. This is what I'm getting now:
Benjamin HP: 718fps
JSB Exact 8.44: 712fps
H&N FTT: 675fps
RWS Hobby: 780fps

Weihrauch advertises 950fps for this gun, some reviews have gotten 900fps with Hobby pellets.

So what should I be looking for? I did notice that with the brand-new seal installed the piston slid down the compression tube quite freely...is that expected or unusual for a never-fired seal?

Any advice is welcome.


Top
 Profile  
 
PostPosted: Fri Jul 01, 2016 12:07 am 
Offline

Joined: Mon Sep 03, 2007 7:56 pm
Posts: 173
Location: Sidney, BC.
Sounds like you need a over sized piston seal...go to
Air Rifle Headquarters = Jim Macarri....he has what you need...KEN.


Top
 Profile  
 
PostPosted: Fri Jul 01, 2016 3:21 pm 
Offline

Joined: Fri Dec 18, 2015 11:31 pm
Posts: 92
It was indeed the piston seal...I put the old one back in (even though it was slightly damaged) and I'm now seeing more like 880fps with JSB Exact, which is at least in the ballpark. I may have to order a couple new oversized ones as spares.

There's a slight whiff of combustion when firing (no loud bang or smoke though), so I figure the power level may drop down slightly as everything settles in.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
News News Site map Site map SitemapIndex SitemapIndex RSS Feed RSS Feed Channel list Channel list

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

phpBB SEO