Canadian Airgun Forum

The #1 Community for Airguns in Canada!
It is currently Fri Feb 28, 2020 3:59 am

All times are UTC - 5 hours


The Canadian Airgun Forums are a place for people to discuss and learn about airguns and the airgunning sport in Canada. There are lots of discussions about airguns, airgun accessories, reviews, modification and repair information, airgun events, field target and free classifieds!

 

You need to register before you can post: click the register link to proceed. Before you register, please read the forum rules. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload your own pictures, and access many other special features. Registration is fast, simple, and absolutely free! To start viewing messages, select the forum that you want to visit from the selection below.








Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Fri Jan 17, 2020 1:08 pm 
Offline

Joined: Tue Jan 14, 2020 8:13 am
Posts: 6
After I assembly the 586, when I dryfire, the lever that rotates the cylinder(1) will get pushed out(2). Therefore, once I install the magazine, I can't pull the trigger. Does anyone have any idea of what I did wrong?

(1): EC184 in this diagram https://www.gunspares.co.uk/showcatimage.asp?id=24515

(2): https://imgur.com/gysg3uS


Top
 Profile  
 
PostPosted: Fri Jan 17, 2020 3:01 pm 
Offline

Joined: Mon Sep 05, 2005 10:55 pm
Posts: 6887
Location: Rocky Mtn Hse Alberta
Pic with side plate off?
Iirc we have a section to make your introduction.
Please tell us a bit about yourself over there.
Cheers

_________________
Image
Walter


Top
 Profile  
 
PostPosted: Sat Jan 18, 2020 3:31 am 
Offline

Joined: Tue Jan 14, 2020 8:13 am
Posts: 6
Voltar1 wrote:
Pic with side plate off?
Iirc we have a section to make your introduction.
Please tell us a bit about yourself over there.
Cheers

I made the pin from a paper clip to replace DP420(https://imgur.com/a/219Zumk). But even if I remove the pin, the issue is still there. Maybe I need to make a pin which is identical to the original one? Or I lost some other part?

This is how it looks when I remove the side plate after the issue happened.

https://imgur.com/kwsk6Ch

https://imgur.com/wb2oxMl


Top
 Profile  
 
PostPosted: Sat Jan 18, 2020 3:46 am 
Offline

Joined: Tue Jan 14, 2020 8:13 am
Posts: 6
Thanks for all your reply, I think I solved the problem. I though the lever should install in this way(https://imgur.com/RmnnwDL), but it should install like this(https://imgur.com/9Van4CL). But I do need to make a pin that is identical to the original one, that little diameter makes a difference.


Top
 Profile  
 
PostPosted: Sat Jan 18, 2020 11:15 am 
Offline
User avatar

Joined: Mon Feb 11, 2013 12:46 am
Posts: 4328
you just made a little mistake reinstalling it back together that's all...
the pin on the lever that rotates the mag pic#1 needs to sit inside the other lever
that's connected to the trigger mechanism pic#2... then you should be good.... :wink:

Image
Image

_________________
"A candle loses nothing by lighting another candle"

Image


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
News News Site map Site map SitemapIndex SitemapIndex RSS Feed RSS Feed Channel list Channel list

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

phpBB SEO